CRS default trunked vlan script
Hey All, I've been playing around with v6.13rc1-12 over the last week on a CRS125-24G-1S and have put together a an example script for provisioning the CRSwitches with a user and admin vlan that is trunked back via the SFP port. Hopefully this is useful to some of us; I know I've been waiting for a long time to have a usable and readable switch chip config on the CRS platform :-) In the config: vlan20 is the user facing vlan (untagged on ether1-24, tagged on sfp1) vlan90 is the admin vlan (tagged on sfp1) vlan90 is attached to the router cpu 10.0.0.2/24 is assigned to vlan90 10.0.0.1 is set as the default gateway Cheers, Andrew Cox
So,.. You are saying that it was not possible to script this previously? And by 'useable and readable' I think you mean 'not something totally unintuitive and confusing'? :-D (did you intend to attach a copy of your script, or just tantalising us with the possibility? :) Cheers.
-----Original Message----- From: Public [mailto:public-bounces@talk.mikrotik.com.au] On Behalf Of Andrew Cox Sent: Wednesday, 7 May 2014 10:33 AM To: MikroTik Australia Public List Subject: [MT-AU Public] CRS default trunked vlan script
Hey All,
I've been playing around with v6.13rc1-12 over the last week on a CRS125-24G- 1S and have put together a an example script for provisioning the CRSwitches with a user and admin vlan that is trunked back via the SFP port.
Hopefully this is useful to some of us; I know I've been waiting for a long time to have a usable and readable switch chip config on the CRS platform :-)
In the config: vlan20 is the user facing vlan (untagged on ether1-24, tagged on sfp1) vlan90 is the admin vlan (tagged on sfp1) vlan90 is attached to the router cpu 10.0.0.2/24 is assigned to vlan90 10.0.0.1 is set as the default gateway
Cheers, Andrew Cox _______________________________________________ Public mailing list Public@talk.mikrotik.com.au http://talk.mikrotik.com.au/mailman/listinfo/public_talk.mikrotik.com.au
I believe it was possible (according to mikrotik anyway) but I was never able to get it to work and even in the v6.12 revised version theres an issue if you reboot the switch with this config. And yeah, usable and readable = not ridiculously hard to understand and change to suit your needs. It was attached but I think the list mailer dropped it; here's it in text: == /interface vlan add interface=sfp1 l2mtu=1584 name=vid90 vlan-id=90 /interface ethernet set [ find default-name=ether1 ] master-port=sfp1 set [ find default-name=ether2 ] master-port=sfp1 set [ find default-name=ether3 ] master-port=sfp1 set [ find default-name=ether4 ] master-port=sfp1 set [ find default-name=ether5 ] master-port=sfp1 set [ find default-name=ether6 ] master-port=sfp1 set [ find default-name=ether7 ] master-port=sfp1 set [ find default-name=ether8 ] master-port=sfp1 set [ find default-name=ether9 ] master-port=sfp1 set [ find default-name=ether10 ] master-port=sfp1 set [ find default-name=ether11 ] master-port=sfp1 set [ find default-name=ether12 ] master-port=sfp1 set [ find default-name=ether13 ] master-port=sfp1 set [ find default-name=ether14 ] master-port=sfp1 set [ find default-name=ether15 ] master-port=sfp1 set [ find default-name=ether16 ] master-port=sfp1 set [ find default-name=ether17 ] master-port=sfp1 set [ find default-name=ether18 ] master-port=sfp1 set [ find default-name=ether19 ] master-port=sfp1 set [ find default-name=ether20 ] master-port=sfp1 set [ find default-name=ether21 ] master-port=sfp1 set [ find default-name=ether22 ] master-port=sfp1 set [ find default-name=ether23 ] master-port=sfp1 set [ find default-name=ether24 ] master-port=sfp1 /interface ethernet switch egress-vlan-tag add tagged-ports=sfp1 vlan-id=20 add tagged-ports=sfp1,switch1-cpu vlan-id=90 /interface ethernet switch ingress-vlan-translation add new-customer-vid=20 ports=ether1 sa-learning=yes add new-customer-vid=20 ports=ether2 sa-learning=yes add new-customer-vid=20 ports=ether3 sa-learning=yes add new-customer-vid=20 ports=ether4 sa-learning=yes add new-customer-vid=20 ports=ether5 sa-learning=yes add new-customer-vid=20 ports=ether6 sa-learning=yes add new-customer-vid=20 ports=ether7 sa-learning=yes add new-customer-vid=20 ports=ether8 sa-learning=yes add new-customer-vid=20 ports=ether9 sa-learning=yes add new-customer-vid=20 ports=ether10 sa-learning=yes add new-customer-vid=20 ports=ether11 sa-learning=yes add new-customer-vid=20 ports=ether12 sa-learning=yes add new-customer-vid=20 ports=ether13 sa-learning=yes add new-customer-vid=20 ports=ether14 sa-learning=yes add new-customer-vid=20 ports=ether15 sa-learning=yes add new-customer-vid=20 ports=ether16 sa-learning=yes add new-customer-vid=20 ports=ether17 sa-learning=yes add new-customer-vid=20 ports=ether18 sa-learning=yes add new-customer-vid=20 ports=ether19 sa-learning=yes add new-customer-vid=20 ports=ether20 sa-learning=yes add new-customer-vid=20 ports=ether21 sa-learning=yes add new-customer-vid=20 ports=ether22 sa-learning=yes add new-customer-vid=20 ports=ether23 sa-learning=yes add new-customer-vid=20 ports=ether24 sa-learning=yes /ip address add address=10.0.0.2/24 interface=vid90 network=10.0.0.0 /ip route add dst-address=0.0.0.0/0 gateway=10.0.0.1 == On 7 May 2014 10:49, Mike Everest <mike@duxtel.com> wrote:
So,..
You are saying that it was not possible to script this previously?
And by 'useable and readable' I think you mean 'not something totally unintuitive and confusing'? :-D
(did you intend to attach a copy of your script, or just tantalising us with the possibility? :)
Cheers.
-----Original Message----- From: Public [mailto:public-bounces@talk.mikrotik.com.au] On Behalf Of Andrew Cox Sent: Wednesday, 7 May 2014 10:33 AM To: MikroTik Australia Public List Subject: [MT-AU Public] CRS default trunked vlan script
Hey All,
I've been playing around with v6.13rc1-12 over the last week on a CRS125-24G- 1S and have put together a an example script for provisioning the CRSwitches with a user and admin vlan that is trunked back via the SFP port.
Hopefully this is useful to some of us; I know I've been waiting for a long time to have a usable and readable switch chip config on the CRS platform :-)
In the config: vlan20 is the user facing vlan (untagged on ether1-24, tagged on sfp1) vlan90 is the admin vlan (tagged on sfp1) vlan90 is attached to the router cpu 10.0.0.2/24 is assigned to vlan90 10.0.0.1 is set as the default gateway
Cheers, Andrew Cox _______________________________________________ Public mailing list Public@talk.mikrotik.com.au http://talk.mikrotik.com.au/mailman/listinfo/public_talk.mikrotik.com.au
_______________________________________________ Public mailing list Public@talk.mikrotik.com.au http://talk.mikrotik.com.au/mailman/listinfo/public_talk.mikrotik.com.au
I'm personally waiting for 802.3ad or LACP support in hardware on the CRS - any signs of that appearing yet in the latest RC of v6.13? Cheers, Andrew. -----Original Message----- From: Public [mailto:public-bounces@talk.mikrotik.com.au] On Behalf Of Andrew Cox Sent: Wednesday, 7 May 2014 10:33 AM To: MikroTik Australia Public List Subject: [MT-AU Public] CRS default trunked vlan script Hey All, I've been playing around with v6.13rc1-12 over the last week on a CRS125-24G-1S and have put together a an example script for provisioning the CRSwitches with a user and admin vlan that is trunked back via the SFP port. Hopefully this is useful to some of us; I know I've been waiting for a long time to have a usable and readable switch chip config on the CRS platform :-) In the config: vlan20 is the user facing vlan (untagged on ether1-24, tagged on sfp1) vlan90 is the admin vlan (tagged on sfp1) vlan90 is attached to the router cpu 10.0.0.2/24 is assigned to vlan90 10.0.0.1 is set as the default gateway Cheers, Andrew Cox _______________________________________________ Public mailing list Public@talk.mikrotik.com.au http://talk.mikrotik.com.au/mailman/listinfo/public_talk.mikrotik.com.au Important Notice: The contents of this email are intended solely for the named addressee and are confidential; any unauthorised use, reproduction or storage of the contents is expressly prohibited. If you have received this email in error, please delete it and any attachments immediately and advise the sender by return email or telephone. Deakin University does not warrant that this email and any attachments are error or virus free.
-----Original Message----- From: Public [mailto:public-bounces@talk.mikrotik.com.au] On Behalf Of Andrew Van Slageren Sent: Wednesday, 7 May 2014 10:54 AM To: MikroTik Australia Public List Subject: Re: [MT-AU Public] CRS default trunked vlan script
I'm personally waiting for 802.3ad or LACP support in hardware on the CRS
Can't say for sure, but if it were available in hardware, then I reckon they would have offered a dodgy interface to control it already - at least from shell ;) I'd say that if it is not available now, then it won't become available through software update - only new hardware models. :( Cheers! -
any signs of that appearing yet in the latest RC of v6.13?
Cheers, Andrew.
-----Original Message----- From: Public [mailto:public-bounces@talk.mikrotik.com.au] On Behalf Of Andrew Cox Sent: Wednesday, 7 May 2014 10:33 AM To: MikroTik Australia Public List Subject: [MT-AU Public] CRS default trunked vlan script
Hey All,
I've been playing around with v6.13rc1-12 over the last week on a CRS125-24G- 1S and have put together a an example script for provisioning the CRSwitches with a user and admin vlan that is trunked back via the SFP port.
Hopefully this is useful to some of us; I know I've been waiting for a long time to have a usable and readable switch chip config on the CRS platform :-)
In the config: vlan20 is the user facing vlan (untagged on ether1-24, tagged on sfp1) vlan90 is the admin vlan (tagged on sfp1) vlan90 is attached to the router cpu 10.0.0.2/24 is assigned to vlan90 10.0.0.1 is set as the default gateway
Cheers, Andrew Cox _______________________________________________ Public mailing list Public@talk.mikrotik.com.au http://talk.mikrotik.com.au/mailman/listinfo/public_talk.mikrotik.com.au
Important Notice: The contents of this email are intended solely for the named addressee and are confidential; any unauthorised use, reproduction or storage of the contents is expressly prohibited. If you have received this email in error, please delete it and any attachments immediately and advise the sender by return email or telephone.
Deakin University does not warrant that this email and any attachments are error or virus free.
_______________________________________________ Public mailing list Public@talk.mikrotik.com.au http://talk.mikrotik.com.au/mailman/listinfo/public_talk.mikrotik.com.au
participants (3)
-
Andrew Cox
-
Andrew Van Slageren
-
Mike Everest